Jump to content
buck5ca

07 road king cutting out

Recommended Posts

buck5ca

I really need some help. I have an 07 Road King, after 20-30 min.'s of riding bike will stumble and die when rolling off the throttle but starts right back up when i hit starter button, I have dynjet fuel pack, rynhart pipes and s&s breather , cam, (full stage one), have had on a dyno and re-mapped ,idle plate adjusted , intake gaskets replaced, still same old problem .It's getting expensive now to keep going to shop! People have said could be crank  sensor, ignition coil break down ,breakers in ignition system.... Help !!!! being overwhelmed .Has anyone had this problem? any other ideas? Thanks for any help

Share this post


Link to post
Share on other sites
buck5ca

Had the same issue with my 07 Road Glide (Power Commander, K&N filter, stock mufflers) a month ago. I traced the cause to a very dirty air filter and stretched throttle cables, but it's doubtful yours will be that easy to fix. Check the throttle cable slack anyways just to make sure, you should only have about 1/16th rotation of free play when you twist the throttle grip. I doubt that it is the ignition coil, as they do not normally recover that quickly - it's usually an open circuit caused by heat and it does not function again until the coil has cooled off. Same thing with crank sensor.

thanks for the info, brand new S&S breather ,filter and new intake gaskets, it had more than 1/16 in play in throttle cable(took up extra) ,seen on line a couple of instances were crank censor was a problem , will get shop to check it ,was also wondering if anybody has had problem with faulty power comanders and what symtoms are , thanks again for input

Share this post


Link to post
Share on other sites
buck5ca

hoping to get checked out again this week

Share this post


Link to post
Share on other sites
Spaz

Hi I have a 2007 FLT Touring I had  the dynjet powercommander  with K&N filter and S&S slip-on. I had

problems the way the bike ran ,so I disconnected the dynjet and ran without it to test it, it was lean but ran ok .I sold the dynjet

and got a Cobra IF 2000 Pro which is very easy to install and there is no mapping. It reads  the O2 sensors 80 times per second

and tunes the bike all the time . Since then I installed 103 and running the cobra and it is working great .You can go on the internet

and look up Cobra IF 2000 Pro on the YouTube you will be impressed with this tuner . You can call me to at 519-786-2895

Henry 

Share this post


Link to post
Share on other sites

×
×
  • Create New...